summaryrefslogtreecommitdiffstats
path: root/font/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'font/Cargo.toml')
-rw-r--r--font/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/font/Cargo.toml b/font/Cargo.toml
new file mode 100644
index 00000000..8345af73
--- /dev/null
+++ b/font/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "font"
+version = "0.1.0"
+authors = ["Joe Wilm <joe@jwilm.com>"]
+description = "Font rendering using the best available solution per platform"
+license = "Apache-2.0"
+
+[dependencies]
+euclid = "0.6.8"
+
+[target.'cfg(not(target_os = "macos"))'.dependencies]
+servo-fontconfig = { git = "https://github.com/jwilm/rust-fontconfig" }
+freetype-rs = "0.9.0"
+libc = "0.2.11"
+
+[target.'cfg(target_os = "macos")'.dependencies]
+core-text = "1.1.1"
+core-foundation = "0.2.2"
+core-graphics = "0.3.2"
+core-foundation-sys = "0.2.2"