summaryrefslogtreecommitdiffstats
path: root/tokio-util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tokio-util/Cargo.toml')
-rw-r--r--tokio-util/Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/tokio-util/Cargo.toml b/tokio-util/Cargo.toml
index 8e5542be..356712c6 100644
--- a/tokio-util/Cargo.toml
+++ b/tokio-util/Cargo.toml
@@ -19,6 +19,16 @@ Additional utilities for working with Tokio.
"""
categories = ["asynchronous"]
+[features]
+# No features on by default
+default = []
+
+# Shorthand for enabling everything
+full = ["codec", "udp"]
+
+codec = []
+udp = ["tokio/udp"]
+
[dependencies]
tokio = { version = "=0.2.0-alpha.6", path = "../tokio" }
@@ -29,10 +39,11 @@ log = "0.4"
pin-project-lite = "0.1.1"
[dev-dependencies]
-tokio = { version = "=0.2.0-alpha.6", path = "../tokio" }
+tokio = { version = "=0.2.0-alpha.6", path = "../tokio", features = ["full"] }
tokio-test = { version = "=0.2.0-alpha.6", path = "../tokio-test" }
futures = "0.3.0"
[package.metadata.docs.rs]
all-features = true
+rustdoc-args = ["--cfg", "docsrs"]