summaryrefslogtreecommitdiffstats
path: root/tokio-executor/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tokio-executor/Cargo.toml')
-rw-r--r--tokio-executor/Cargo.toml52
1 files changed, 0 insertions, 52 deletions
diff --git a/tokio-executor/Cargo.toml b/tokio-executor/Cargo.toml
deleted file mode 100644
index d1bd6a18..00000000
--- a/tokio-executor/Cargo.toml
+++ /dev/null
@@ -1,52 +0,0 @@
-[package]
-name = "tokio-executor"
-# When releasing to crates.io:
-# - Remove path dependencies
-# - Update html_root_url.
-# - Update doc url
-# - Cargo.toml
-# - Update CHANGELOG.md.
-# - Create "v0.2.x" git tag.
-version = "0.2.0-alpha.6"
-edition = "2018"
-documentation = "https://docs.rs/tokio-executor/0.2.0-alpha.6/tokio_executor"
-repository = "https://github.com/tokio-rs/tokio"
-homepage = "https://github.com/tokio-rs/tokio"
-license = "MIT"
-authors = ["Tokio Contributors <team@tokio.rs>"]
-description = """
-Future execution primitives
-"""
-keywords = ["futures", "tokio"]
-categories = ["concurrency", "asynchronous"]
-
-[features]
-blocking = ["lazy_static"]
-current-thread = ["crossbeam-channel"]
-thread-pool = ["num_cpus"]
-
-[dependencies]
-futures-util-preview = { version = "=0.3.0-alpha.19", features = ["channel"] }
-tokio-sync = { version = "=0.2.0-alpha.6", path = "../tokio-sync" }
-
-# current-thread dependencies
-crossbeam-channel = { version = "0.3.8", optional = true }
-
-# threadpool dependencies
-num_cpus = { version = "1.2", optional = true }
-
-# blocking
-futures-core-preview = { version = "=0.3.0-alpha.19", optional = true }
-lazy_static = { version = "1", optional = true }
-
-[dev-dependencies]
-tokio = { version = "=0.2.0-alpha.6", path = "../tokio" }
-tokio-sync = { version = "=0.2.0-alpha.6", path = "../tokio-sync" }
-tokio-test = { version = "=0.2.0-alpha.6", path = "../tokio-test" }
-
-futures-core-preview = "=0.3.0-alpha.19"
-loom = { version = "0.2.11", features = ["futures", "checkpoint"] }
-rand = "0.7"
-
-[package.metadata.docs.rs]
-all-features = true