summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2022-02-16 12:26:23 +0000
committerNicholas Marriott <nicholas.marriott@gmail.com>2022-02-16 12:26:23 +0000
commitc7c7e875a0f71451564746a20db8d84c418ad7d5 (patch)
tree8d8f4f4b9b838bb958d563d76177f9ddc14dca5d /configure.ac
parent85ef73591da51be51c0ead6e7ae4414e349d46d3 (diff)
No not allow static linking on macOS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 26bd1a98..edda0d6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,11 @@ AC_ARG_ENABLE(
AS_HELP_STRING(--enable-static, create a static build)
)
if test "x$enable_static" = xyes; then
+ case "$host_os" in
+ *darwin*)
+ AC_MSG_ERROR([static linking is not supported on macOS])
+ ;;
+ esac
test "x$PKG_CONFIG" != x && PKG_CONFIG="$PKG_CONFIG --static"
AM_LDFLAGS="-static $AM_LDFLAGS"
LDFLAGS="$AM_LDFLAGS $SAVED_LDFLAGS"