summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicholas Marriott <nicholas.marriott@gmail.com>2022-08-02 11:52:09 +0100
committerNicholas Marriott <nicholas.marriott@gmail.com>2022-08-02 11:52:09 +0100
commit00812c9053a0b1067f833925b726086a67d8528d (patch)
tree0fdf9e8c570fd4ed5ac0f883164b0680a6ca2cbb /configure.ac
parent9d9445a48e626731e9384b6b9cda367cd4cef5d3 (diff)
Check for $YACC, from Wei Shih in GitHub issue 3267.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 276f71c8..8e846042 100644
--- a/configure.ac
+++ b/configure.ac
@@ -267,6 +267,12 @@ if test "x$found_libevent" = xno; then
AC_MSG_ERROR("libevent not found")
fi
+# Look for yacc.
+AC_CHECK_PROG(found_yacc, $YACC, yes, no)
+if test "x$found_yacc" = xno; then
+ AC_MSG_ERROR("yacc not found")
+fi
+
# Look for ncurses or curses. Try pkg-config first then directly for the
# library.
PKG_CHECK_MODULES(