summaryrefslogtreecommitdiffstats
path: root/packages/svgbob/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'packages/svgbob/Cargo.toml')
-rw-r--r--packages/svgbob/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/svgbob/Cargo.toml b/packages/svgbob/Cargo.toml
new file mode 100644
index 0000000..a81790c
--- /dev/null
+++ b/packages/svgbob/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "svgbob"
+version = "0.6.2"
+authors = ["Jovansonlee Cesar <ivanceras@gmail.com>"]
+edition = "2018"
+description = "Transform your ascii diagrams into happy little SVG"
+repository = "https://github.com/ivanceras/svgbob"
+documentation = "https://docs.rs/svgbob"
+keywords = ["ascii","plain","text", "svg", "bob"]
+license = "Apache-2.0"
+
+[dependencies]
+nalgebra = "0.29"
+parry2d = "0.7"
+lazy_static = "1.3.0"
+sauron = { version = "0.43.4", default-features = false}
+#sauron = { version = "0.43", default-features = false, path = "../../../sauron"}
+unicode-width = "0.1.5"
+itertools = "0.8.0"
+pom = { version = "3.1.0" }
+log = "0.4"
+
+
+
+[features]
+# This affects the rendering of text nodes
+# if the svg is rendered statically, characters such as '<' needed to be escaped
+# while if it is rendered in the dom, no escaping is needed.
+with-dom = ["sauron/with-dom"]
+