summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrew Gallant <jamslam@gmail.com>2024-03-07 09:31:22 -0500
committerAndrew Gallant <jamslam@gmail.com>2024-03-07 09:47:43 -0500
commite9abbc1a02de29dbe60e1b625d540c58759b23a6 (patch)
treedd9d7113dd719a325903dafd2f848f7ccf3cfc62 /Cargo.toml
parent9bd30e8e48b139c3f5ebe8587abff6fff7add45b (diff)
cargo: nuke 'simd-accel' from orbit
This feature causes nothing but problems and is frequently broken. The only optimization it was enabling were SIMD optimizations for transcoding. In particular, for UTF-16 transcoding. This is performed by the [`encoding_rs`](https://github.com/hsivonen/encoding_rs) crate, which specifically uses unstable portable SIMD APIs instead of the stable non-portable SIMD APIs. SIMD optimizations that apply to search have long been making use of stable APIs, and are automatically enabled when your target supports them. This is, IMO, the correct user experience and one that `encoding_rs` refuses to support. I'm done dealing with it, so transcoding will only use scalar code until the SIMD optimizations in `encoding_rs` work on stable. (This doesn't mean that `encoding_rs` has to change. This could also be fixed by stabilizing `std::simd`.) Fixes #2748
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index da350bc8..6bb068b8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -68,7 +68,6 @@ serde_derive = "1.0.77"
walkdir = "2"
[features]
-simd-accel = ["grep/simd-accel"]
pcre2 = ["grep/pcre2"]
[profile.release]