summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 508d020..11a0753 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,7 +247,7 @@ else(LIBTERMCAP)
if(LIBCURSES)
target_link_libraries(${PROJECT_NAME} ${LIBCURSES})
else(LIBCURSES)
- find_library(LIBNCURSES ncurses)
+ find_library(LIBNCURSES ncurses REQUIRED)
if(LIBNCURSES)
target_link_libraries(${PROJECT_NAME} ${LIBNCURSES})
endif(LIBNCURSES)
@@ -259,7 +259,7 @@ if(LIBKSTAT)
target_link_libraries(${PROJECT_NAME} ${LIBKSTAT})
endif(LIBKSTAT)
-find_library(LIBELF elf)
+find_library(LIBELF elf REQUIRED)
if(LIBELF)
target_link_libraries(${PROJECT_NAME} ${LIBELF})
endif(LIBELF)
@@ -269,7 +269,7 @@ if(LIBMACH)
target_link_libraries(${PROJECT_NAME} ${LIBMACH})
endif(LIBMACH)
-find_library(LIBBSD bsd)
+find_library(LIBBSD bsd REQUIRED)
if(LIBBSD)
target_link_libraries(${PROJECT_NAME} ${LIBBSD})
endif(LIBBSD)