summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2023-12-18 14:49:11 +1100
committerDamien Miller <djm@mindrot.org>2023-12-18 14:49:11 +1100
commit59d691b886c79e70b1d1c4ab744e81fd176222fd (patch)
treecd06e8849c605bac35706a60db7e9c65dd75d8cc /configure.ac
parentaa7b21708511a6d4aed3839fc9f6e82e849dd4a1 (diff)
better detection of broken -fzero-call-used-regs
Use OSSH_CHECK_CFLAG_LINK() for detection of these flags and extend test program to exercise varargs, which seems to catch more stuff. ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 36e1028e..379cd746 100644
--- a/configure.ac
+++ b/configure.ac
@@ -234,9 +234,9 @@ if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
# clang 17 has a different bug that causes an ICE when using this
# flag at all (https://bugzilla.mindrot.org/show_bug.cgi?id=3629)
case "$CLANG_VER" in
- apple-15*) OSSH_CHECK_CFLAG_COMPILE([-fzero-call-used-regs=used]) ;;
+ apple-15*) OSSH_CHECK_CFLAG_LINK([-fzero-call-used-regs=used]) ;;
17*) ;;
- *) OSSH_CHECK_CFLAG_COMPILE([-fzero-call-used-regs=used]) ;;
+ *) OSSH_CHECK_CFLAG_LINK([-fzero-call-used-regs=used]) ;;
esac
OSSH_CHECK_CFLAG_COMPILE([-ftrivial-auto-var-init=zero])
fi