summaryrefslogtreecommitdiffstats
path: root/supermicro/a1sri-2758f.nix
diff options
context:
space:
mode:
Diffstat (limited to 'supermicro/a1sri-2758f.nix')
-rw-r--r--supermicro/a1sri-2758f.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/supermicro/a1sri-2758f.nix b/supermicro/a1sri-2758f.nix
index 3471704..b199bf1 100644
--- a/supermicro/a1sri-2758f.nix
+++ b/supermicro/a1sri-2758f.nix
@@ -6,11 +6,25 @@
{ pkgs, ... }:
{
+ imports = [ ../lib/hardware-notes.nix ];
+
environment.systemPackages = [ pkgs.ipmitool ];
boot.kernelModules = [ "ipmi_devintf" "ipmi_si" ];
- # The Linux NIC driver seems to have faulty link state reporting
- # that causes dhcpcd to release every few seconds, which is
- # more annoying than not releasing when a cable is unplugged.
networking.dhcpcd.extraConfig = "nolink";
+
+ hardwareNotes =
+ [ { title = "IPMI";
+ text = "Load IPMI kernel modules and ipmitool to system environment.";
+ }
+ { title = "Nolink";
+ text =
+ ''
+ Interface link state detection is disabled in dhcpcd because
+ the Linux driver seems to send erronous loss of link messages
+ that cause dhcpcd to release every few seconds, which is
+ more annoying than not releasing when a cable is unplugged.
+ '';
+ }
+ ];
}