summaryrefslogtreecommitdiffstats
path: root/lenovo/thinkpad/x220/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lenovo/thinkpad/x220/default.nix')
-rw-r--r--lenovo/thinkpad/x220/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/lenovo/thinkpad/x220/default.nix b/lenovo/thinkpad/x220/default.nix
new file mode 100644
index 0000000..3a9e99b
--- /dev/null
+++ b/lenovo/thinkpad/x220/default.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [ ../intel.nix ];
+
+ # TPM chip countains a RNG
+ security.rngd.enable = true;
+
+ boot = {
+ kernelModules = [ "tp_smapi" ];
+ extraModulePackages = with config.boot.kernelPackages; [ tp_smapi ];
+ };
+
+ # hard disk protection if the laptop falls
+ services.hdapsd.enable = true;
+
+ # fingerprint reader: login and unlock with fingerprint (if you add one with `fprintd-enroll`)
+ #services.fprintd.enable = true;
+ #security.pam.services.login.fprintAuth = true;
+ #security.pam.services.xscreensaver.fprintAuth = true;
+ # similarly for other PAM providers
+}