summaryrefslogtreecommitdiffstats
path: root/apple/macbook-pro/10-1/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'apple/macbook-pro/10-1/default.nix')
-rw-r--r--apple/macbook-pro/10-1/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/apple/macbook-pro/10-1/default.nix b/apple/macbook-pro/10-1/default.nix
index 0fa8a2f..06e7486 100644
--- a/apple/macbook-pro/10-1/default.nix
+++ b/apple/macbook-pro/10-1/default.nix
@@ -1,16 +1,19 @@
{ lib, pkgs, ... }:
{
- imports = [ ../../. ];
+ imports = [
+ ../.
+ ../../../common/pc/laptop/ssd
+ ];
+ # TODO: boot loader
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
+ # TODO: drop
hardware.opengl.driSupport32Bit = true;
services.xserver = {
- libinput.enable = lib.mkDefault true;
-
# TODO: we should not enable unfree drivers
# when there is an alternative (i.e. nouveau)
videoDrivers = [ "nvidia" ];