summaryrefslogtreecommitdiffstats
path: root/include/djinterop/meson.build
diff options
context:
space:
mode:
authorAdam Szmigin <smidge@xsco.net>2020-10-06 14:24:06 +0100
committerGitHub <noreply@github.com>2020-10-06 14:24:06 +0100
commitfe21c4d6dae9f14a7a2097dce0d7b5a7d84178d5 (patch)
tree3680042c5f8a0981db070c21b76c26f98848bd16 /include/djinterop/meson.build
parent2fb8d7e1811090bcea1ab204407936b408fa5ec3 (diff)
parent9d1fbbbc96705410a662af5858ca4df8a40796e9 (diff)
Merge pull request #31 from xsco/fix/msvc-static-lib-build
Fix static builds on MSVC
Diffstat (limited to 'include/djinterop/meson.build')
-rw-r--r--include/djinterop/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/djinterop/meson.build b/include/djinterop/meson.build
index c43a0b2..1ec6646 100644
--- a/include/djinterop/meson.build
+++ b/include/djinterop/meson.build
@@ -4,6 +4,9 @@
# of configure_file() does not, at the time of writing (meson 0.55.0), support
# writing the output file to a different directory.
conf_data = configuration_data()
+if default_library_type == 'static'
+ conf_data.set10('DJINTEROP_STATIC', true)
+endif
if cpp_compiler.has_header('optional')
conf_data.set10('DJINTEROP_STD_OPTIONAL', true)
endif