summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMattias Wadman <mattias.wadman@gmail.com>2023-07-24 11:34:21 +0200
committerNico Williams <nico@cryptonector.com>2023-07-24 11:26:17 -0500
commit54fef09ac39d6fb003367d65709349c43078405e (patch)
tree7ca75cdbecd2a3f271f395966d5f7ac8ff808050 /configure.ac
parent4cc99831e44ccda5731b91084f6de3fa52ef9ce8 (diff)
Make maintainer-mode default to disabled
This makes the standard build instructions a bit easier, just ./configure, and also requires less tools installed (bison). Also i think few people probably want to generate the lexer and paser code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a100a55e..9e8830bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ AC_USE_SYSTEM_EXTENSIONS
AM_INIT_AUTOMAKE([1.11.2 subdir-objects parallel-tests foreign -Wall])
AM_SILENT_RULES([yes])
AM_PROG_AR
-AM_MAINTAINER_MODE([enable])
+AM_MAINTAINER_MODE([disable])
AC_PROG_CC
m4_version_prereq([2.70], [], [AC_PROG_CC_STDC])
AC_PROG_CPP_WERROR
@@ -33,7 +33,7 @@ if test "$USE_MAINTAINER_MODE" = yes; then
else
AX_PROG_BISON_VERSION([3],
[],
- [AC_MSG_ERROR([You need bison version 3.0 or greater, or use --disable-maintainer-mode.])])
+ [AC_MSG_ERROR([You need bison version 3.0 or greater])])
fi
AC_CHECK_PROGS(LEX, flex lex)