summaryrefslogtreecommitdiffstats
path: root/lib/core/libimagrt/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2018-02-26 22:43:26 +0100
committerMatthias Beyer <mail@beyermatthias.de>2018-03-04 13:57:02 +0100
commitc18c0bbbe455119c935510bd6fb65292e97950b1 (patch)
treecb8e82ceae30ce8c6d90e48a8a024a59fdc4bcbf /lib/core/libimagrt/Cargo.toml
parentf88884c3215fd264088aab22d33c187923f22026 (diff)
Provide stdin/out/err resources via Runtime object
This way we can control whether "out" output goes to stdout or stderr without the user of the functionality knowing. This is useful for later when we use libimagrt to automatically read and write the store from and to stdout/in depending on whether we are talking to a TTY or a pipe.
Diffstat (limited to 'lib/core/libimagrt/Cargo.toml')
-rw-r--r--lib/core/libimagrt/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/core/libimagrt/Cargo.toml b/lib/core/libimagrt/Cargo.toml
index e8a569ba..11e38d5f 100644
--- a/lib/core/libimagrt/Cargo.toml
+++ b/lib/core/libimagrt/Cargo.toml
@@ -29,6 +29,7 @@ is-match = "0.1"
toml-query = "0.6"
error-chain = "0.11"
handlebars = "0.29.0"
+atty = "0.2"
libimagstore = { version = "0.7.0", path = "../../../lib/core/libimagstore" }
libimagerror = { version = "0.7.0", path = "../../../lib/core/libimagerror" }