summaryrefslogtreecommitdiffstats
path: root/lib/core/libimagrt/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2018-10-04 16:11:11 +0200
committerMatthias Beyer <mail@beyermatthias.de>2018-10-06 12:22:15 +0200
commit1161562372f58ee557fa9d5e3cb67a79e985716b (patch)
tree57f404b73a2f5cfcd923d34ce6810d5054e47177 /lib/core/libimagrt/Cargo.toml
parent5d901ae41163c02a39e23ee2baf8577f79197411 (diff)
Remove handlebars exception in log implementation
The issue was that the handlebars implementation logs as well and if we use handlebars in the logger implementation that causes recursion which crashes the program. With handlebars 1.0.5, there is a feature[0] to disable logging in handlebars (compiletime) which we use with this patch. The exception-checking in the log implementation can be removed therefore. [0]: https://github.com/sunng87/handlebars-rust/pull/236#issuecomment-427014611 Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'lib/core/libimagrt/Cargo.toml')
-rw-r--r--lib/core/libimagrt/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/core/libimagrt/Cargo.toml b/lib/core/libimagrt/Cargo.toml
index ae3c9a05..2ab0b52a 100644
--- a/lib/core/libimagrt/Cargo.toml
+++ b/lib/core/libimagrt/Cargo.toml
@@ -28,7 +28,6 @@ ansi_term = "0.11"
is-match = "0.1"
toml-query = "0.7"
error-chain = "0.12"
-handlebars = "1.0"
atty = "0.2"
libimagstore = { version = "0.9.0", path = "../../../lib/core/libimagstore" }
@@ -46,6 +45,11 @@ version = "0.4"
default-features = false
features = ["std"]
+[dependencies.handlebars]
+version = "^1.0.5"
+default-features = false
+features = ["no_logging"]
+
[features]
default = []