summaryrefslogtreecommitdiffstats
path: root/bin/domain/imag-notes/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-08-13 21:48:17 +0000
committerMatthias Beyer <mail@beyermatthias.de>2017-08-27 15:12:09 +0200
commit59a3662ac47b0c657781bd1db34bbf9a5a692326 (patch)
tree709f72c44c8d978a5a76abb9036c6f08744a4aa2 /bin/domain/imag-notes/Cargo.toml
parent31254071e5a4bf2f5db9067c5cdb22c25579ac67 (diff)
Reorganize code in subdirs
Diffstat (limited to 'bin/domain/imag-notes/Cargo.toml')
-rw-r--r--bin/domain/imag-notes/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/bin/domain/imag-notes/Cargo.toml b/bin/domain/imag-notes/Cargo.toml
new file mode 100644
index 00000000..e274e3d8
--- /dev/null
+++ b/bin/domain/imag-notes/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "imag-notes"
+version = "0.4.0"
+authors = ["Matthias Beyer <mail@beyermatthias.de>"]
+
+description = "Part of the imag core distribution: imag-notes command"
+
+keywords = ["imag", "PIM", "personal", "information", "management"]
+readme = "../README.md"
+license = "LGPL-2.1"
+
+documentation = "https://matthiasbeyer.github.io/imag/imag_documentation/index.html"
+repository = "https://github.com/matthiasbeyer/imag"
+homepage = "http://imag-pim.org"
+
+[dependencies]
+semver = "0.2.1"
+clap = ">=2.17"
+log = "0.3"
+version = "2.0.1"
+itertools = "0.5"
+
+libimagrt = { version = "0.4.0", path = "../../../lib/core/libimagrt" }
+libimagerror = { version = "0.4.0", path = "../../../lib/core/libimagerror" }
+libimagnotes = { version = "0.4.0", path = "../../../lib/domain/libimagnotes" }
+libimagentryedit = { version = "0.4.0", path = "../../../lib/entry/libimagentryedit" }
+libimagentrytag = { version = "0.4.0", path = "../../../lib/entry/libimagentrytag" }
+libimagutil = { version = "0.4.0", path = "../../../lib/etc/libimagutil" }