summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9a99454..d77ae58 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,9 +28,9 @@ bet = "1.0.2"
char_reader = "0.1"
chrono = "0.4"
clap = { version = "4.4", features = ["derive", "cargo"] }
-clap-help = "1.0"
+clap-help = "1.1"
cli-log = "2.0"
-crokey = "0.4.3"
+crokey = "0.6.3"
crossbeam = "0.8"
custom_error = "1.6"
deser-hjson = "2.2.3"
@@ -58,9 +58,9 @@ splitty = "1.0"
strict = "0.1.4"
syntect = { package = "syntect-no-panic", version = "4.6.1" } # see issue #485
tempfile = "3.2"
-termimad = "0.27.0"
+termimad = "0.29.0"
terminal-clipboard = { version = "0.4.1", optional = true }
-terminal-light = "1.1.1"
+terminal-light = "1.2.0"
toml = "0.8"
trash = "3.1.2"
umask = "2.1.0"
@@ -69,7 +69,7 @@ which = "4.4.0"
xterm-query = { version = "0.1", optional = true }
[dev-dependencies]
-glassbench = "0.3.6"
+glassbench = "0.4"
[target.'cfg(unix)'.dependencies]
lfs-core = "0.11.0"
@@ -107,22 +107,22 @@ harness = false
[patch.crates-io]
# bet = { path = "../bet" }
-# crokey = { path = "../crokey" }
-# clap-help = { path = "../clap-help" }
# cli-log = { path = "../cli-log" }
-# csv2svg = { path = "../csv2svg" }
# crossterm = { path = "../crossterm-rs/crossterm" }
+# csv2svg = { path = "../csv2svg" }
# deser-hjson = { path = "../deser-hjson" }
# glassbench = { path = "../glassbench" }
-# lazy-regex = { path = "../lazy-regex" }
-# lazy-regex-proc_macros = { path = "../lazy-regex/src/proc_macros" }
# lfs-core = { path = "../lfs-core" }
+# minimad = { path = "../minimad" }
# secular = { path = "../secular", features=["normalization"] }
-# strict = { path = "../strict" }
# syntect = { path = "../syntect" }
# syntect-no-panic = { path = "../syntect" }
-# minimad = { path = "../minimad" }
# termimad = { path = "../termimad" }
-# terminal-light = { path = "../terminal-light" }
# terminal-clipboard = { path = "../terminal-clipboard" }
+# terminal-light = { path = "../terminal-light" }
# umask = { path = "../umask" }
+# clap-help = { path = "../clap-help" }
+# crokey = { path = "../crokey" }
+# lazy-regex = { path = "../lazy-regex" }
+# lazy-regex-proc_macros = { path = "../lazy-regex/src/proc_macros" }
+# strict = { path = "../strict" }