summaryrefslogtreecommitdiffstats
path: root/zellij-utils/Cargo.toml
diff options
context:
space:
mode:
authorAram Drevekenin <aram@poor.dev>2023-08-09 22:26:00 +0200
committerGitHub <noreply@github.com>2023-08-09 22:26:00 +0200
commit1bedfc90021558cb201695444107afe5bddd2c17 (patch)
tree38dd31b5ab112aa9b1c3a54edb07331013bf7d87 /zellij-utils/Cargo.toml
parentc3e140cb4b3c0897329bf07ee7f51e9fd402b3df (diff)
feat(plugins): use protocol buffers for serializing across the wasm boundary (#2686)
* work * almost done with command protobuffers * done translating command data structures * mid transferring of every command to protobuff command * transferred plugin_command.rs, now moving on to shim.rs * plugin command working with protobufs * protobuffers in update * protobuf event tests * various TODOs and comments * fix zellij-tile * clean up prost deps * remove version mismatch error * fix panic * some cleanups * clean up event protobuffers * clean up command protobuffers * clean up various protobufs * refactor protobufs * update comments * some transformation fixes * use protobufs for workers * style(fmt): rustfmt * style(fmt): rustfmt * chore(build): add protoc * chore(build): authenticate protoc
Diffstat (limited to 'zellij-utils/Cargo.toml')
-rw-r--r--zellij-utils/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/zellij-utils/Cargo.toml b/zellij-utils/Cargo.toml
index 65398c532..3e5e2dfd8 100644
--- a/zellij-utils/Cargo.toml
+++ b/zellij-utils/Cargo.toml
@@ -42,6 +42,7 @@ shellexpand = "3.0.0"
uuid = { version = "0.8.2", features = ["serde", "v4"] }
async-channel = "1.8.0"
include_dir = "0.7.3"
+prost = "0.11.9"
#[cfg(not(target_family = "wasm"))]
[target.'cfg(not(target_family = "wasm"))'.dependencies]
@@ -55,6 +56,8 @@ notify-debouncer-full = "0.1.0"
[dev-dependencies]
insta = { version = "1.6.0", features = ["backtrace"] }
+[build-dependencies]
+prost-build = "0.11.9"
[features]
# If this feature is NOT set (default):