summaryrefslogtreecommitdiffstats
path: root/zellij-server/Cargo.toml
diff options
context:
space:
mode:
authorspacemaison <tuchsen@protonmail.com>2021-09-22 10:13:21 -0700
committerGitHub <noreply@github.com>2021-09-22 18:13:21 +0100
commitc9372212f68fed52d45590b2dac271ab6270d943 (patch)
tree031f384ab012817656876b5db020b9e9c6a41a1f /zellij-server/Cargo.toml
parentc39f02181052f1c0948001d4ae419009fc0df677 (diff)
feat(plugin): add manifest to allow for plugin configuration (#660)
* feat(plugins-manifest): Add a plugins manifest to allow for more configuration of plugins * refactor(plugins-manifest): Better storage of plugin metadata in wasm_vm * fix(plugins-manifest): Inherit permissions from run configuration * refactor(plugins-manifest): Rename things for more clarity - The Plugins/Plugin structs had "Config" appended to them to clarify that they're metadata about plugins, and not the plugins themselves. - The PluginType::OncePerPane variant was renamed to be just PluginType::Pane, and the documentation clarified to explain what it is. - The "service" nomenclature was completely removed in favor of "headless". * refactor(plugins-manifest): Move security warning into start plugin * refactor(plugins-manifest): Remove hack in favor of standard method * refactor(plugins-manifest): Change display of plugin location The only time that a plugin location is displayed in Zellij is the border of the pane. Having `zellij:strider` display instead of just `strider` was a little annoying, so we're stripping out the scheme information from a locations display. * refactor(plugins-manifest): Add a little more documentation * fix(plugins-manifest): Formatting Co-authored-by: Jesse Tuchsen <not@disclosing>
Diffstat (limited to 'zellij-server/Cargo.toml')
-rw-r--r--zellij-server/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/zellij-server/Cargo.toml b/zellij-server/Cargo.toml
index bc0abe310..c9f98ecf1 100644
--- a/zellij-server/Cargo.toml
+++ b/zellij-server/Cargo.toml
@@ -16,6 +16,7 @@ byteorder = "1.4.3"
daemonize = "0.4.1"
serde_json = "1.0"
unicode-width = "0.1.8"
+url = "2.2.2"
wasmer = "1.0.0"
wasmer-wasi = "1.0.0"
cassowary = "0.3.0"