summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorhar7an <99636919+har7an@users.noreply.github.com>2023-05-09 02:43:28 +0000
committerGitHub <noreply@github.com>2023-05-09 02:43:28 +0000
commit30d0cffa4294b27da88253b5fb24b40044310338 (patch)
tree66e9cbb833571aee022d5739451e0925c32aeefb /Cargo.toml
parent204c41e63f5a134e2f371ee56e0fb29acea64672 (diff)
Use rust 1.67 (#2375)
* rust: Update toolchain version to 1.67 * xtask/pipeline/publish: Drop manual "wait" for crates.io to catch up, which is obsolete with rust 1.66 and up. Cargo does that on its own now. See https://github.com/rust-lang/cargo/pull/11062 * xtask: Add function to obtain asset_dir instead of assembling it on demand throughout the codebase. * xtask/run: Add '--quick-run' flag as a convenient shorthand for `cargo xtask run --data-dir $PROJECT_ROOT/zellij-utils/assets`. * cargo: Add 'q' command alias as a shorthand for 'cargo xtask run --quick-run' * cargo: Update thiserror to 1.0.40 * cargo: Update anyhow to 1.0.70 and specify dependency only once inside `zellij-utils`, not inside the zellij root crate. * cargo: Update names to 0.14.0 * cargo: Update miette to 5.7.0 and re-export the dependency from zellij-utils, to avoid duplicate (incompatible) includes from inside zellij-utils and the root crate. * cargo: Update dialoguer to 0.10.4 * fix formatting * changelog: Add PR #2375
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 4 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f73af05a1..1c16269f2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,16 +13,14 @@ rust-version = "1.60"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-anyhow = "1.0"
-thiserror = "1.0.30"
-names = { version = "0.13.0", default-features = false }
-miette = { version = "3.3.0", features = ["fancy"] }
zellij-client = { path = "zellij-client/", version = "0.37.0" }
zellij-server = { path = "zellij-server/", version = "0.37.0" }
zellij-utils = { path = "zellij-utils/", version = "0.37.0" }
+thiserror = "1.0.40"
+names = { version = "0.14.0", default-features = false }
log = "0.4.17"
-dialoguer = "0.10.1"
-suggest = "0.4"
+dialoguer = "0.10.4"
+suggest = "0.4.0"
[dev-dependencies]
insta = { version = "1.6.0", features = ["backtrace"] }