summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2021-04-21 09:21:30 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2021-04-21 09:22:44 +0800
commite6deacb6953b7d93b3d2329fcccd35dd0ec128a4 (patch)
tree12ebe61a1e185a27cc93baf6ca9f53822c656e98 /Cargo.toml
parent74cc48fc500f7f81a867394e8d6550562500d14f (diff)
Reduce crate size by 4.8MB using `cargo diet`, to 77kB
On top of that I verified that `cargo package` is still able to build, adjusting the includes in the process to assure required assets are packaged, too.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 688080f11..c133c04c5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,6 +7,7 @@ description = "A terminal workspace with batteries included"
license = "MIT"
repository = "https://github.com/zellij-org/zellij"
homepage = "https://zellij.dev"
+include = ["src/**/*", "assets/plugins/*", "assets/layouts/*", "assets/completions/*", "LICENSE.md", "README.md", "build.rs", "!**/*_test.*", "!**/tests/**/*"]
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html