summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index 57e49d68..6589f485 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -53,6 +53,7 @@ net = [
"lazy_static",
"libc",
"mio/os-poll",
+ "mio/os-util",
"mio/tcp",
"mio/udp",
"mio/uds",
@@ -78,6 +79,7 @@ signal = [
"libc",
"mio/os-poll",
"mio/uds",
+ "mio/os-util",
"signal-hook-registry",
"winapi/consoleapi",
]
@@ -107,6 +109,10 @@ tracing = { version = "0.1.16", default-features = false, features = ["std"], op
libc = { version = "0.2.42", optional = true }
signal-hook-registry = { version = "1.1.1", optional = true }
+[target.'cfg(unix)'.dev-dependencies]
+libc = { version = "0.2.42" }
+nix = { version = "0.18.0" }
+
[target.'cfg(windows)'.dependencies.winapi]
version = "0.3.8"
default-features = false