summaryrefslogtreecommitdiffstats
path: root/tokio-util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tokio-util/Cargo.toml')
-rw-r--r--tokio-util/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/tokio-util/Cargo.toml b/tokio-util/Cargo.toml
index 45daa2b1..8c54f27b 100644
--- a/tokio-util/Cargo.toml
+++ b/tokio-util/Cargo.toml
@@ -25,10 +25,11 @@ publish = false
default = []
# Shorthand for enabling everything
-full = ["codec", "compat", "io"]
+full = ["codec", "compat", "io", "time"]
compat = ["futures-io",]
codec = ["tokio/stream"]
+time = ["tokio/time","slab"]
io = []
[dependencies]
@@ -40,6 +41,7 @@ futures-sink = "0.3.0"
futures-io = { version = "0.3.0", optional = true }
log = "0.4"
pin-project-lite = "0.1.4"
+slab = { version = "0.4.1", optional = true } # Backs `DelayQueue`
[dev-dependencies]
tokio = { version = "0.3.0", path = "../tokio", features = ["full"] }