summaryrefslogtreecommitdiffstats
path: root/tokio-tcp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tokio-tcp/Cargo.toml')
-rw-r--r--tokio-tcp/Cargo.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/tokio-tcp/Cargo.toml b/tokio-tcp/Cargo.toml
index 55f3e43e..a6c672f4 100644
--- a/tokio-tcp/Cargo.toml
+++ b/tokio-tcp/Cargo.toml
@@ -21,15 +21,20 @@ TCP bindings for tokio.
categories = ["asynchronous"]
publish = false
+[features]
+incoming = ["futures-core-preview"]
+
[dependencies]
tokio-io = { version = "0.2.0", path = "../tokio-io" }
tokio-reactor = { version = "0.2.0", path = "../tokio-reactor" }
bytes = "0.4"
mio = "0.6.14"
iovec = "0.1"
-futures = "0.1.19"
+
+# optionals
+futures-core-preview = { version = "0.3.0-alpha.16", optional = true }
[dev-dependencies]
-env_logger = { version = "0.5", default-features = false }
-net2 = "*"
-tokio = { version = "0.2.0", path = "../tokio" }
+#env_logger = { version = "0.5", default-features = false }
+#net2 = "*"
+#tokio = { version = "0.2.0", path = "../tokio" }