summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2018-05-02 10:48:58 -0700
committerGitHub <noreply@github.com>2018-05-02 10:48:58 -0700
commit7a2b5db15cc86ed69fb2c9e3796d2caa4affae9c (patch)
treedf23231a93d8471ae588b9765bb7a4f2527e11bc /Cargo.toml
parent246548384558ee0b01252935448cc23b7fd767e2 (diff)
Remove `futures2` feature from Cargo.toml files (#334)
Currently, the state of the futures2 integration is pretty broken. This patch removes the feature flag, preventing users from trying to use it. In the future, it can be brought back when the implementation is fixed.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 0 insertions, 17 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6cac0bcd..8790d71b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -51,9 +51,6 @@ futures = "0.1.20"
# Needed until `reactor` is removed from `tokio`.
mio = "0.6.14"
-# Futures 0.2 integration
-futures2 = { version = "0.1.0", path = "futures2", optional = true }
-
[dev-dependencies]
bytes = "0.4"
env_logger = { version = "0.4", default-features = false }
@@ -67,17 +64,3 @@ serde = "1.0"
serde_derive = "1.0"
serde_json = "1.0"
time = "0.1"
-
-[patch.crates-io]
-tokio-io = { path = "tokio-io" }
-
-[features]
-unstable-futures = [
- "futures2",
- "tokio-reactor/unstable-futures",
- "tokio-threadpool/unstable-futures",
- "tokio-executor/unstable-futures",
- "tokio-tcp/unstable-futures",
- "tokio-udp/unstable-futures"
-]
-default = []