summaryrefslogtreecommitdiffstats
path: root/sm/plugin_sm/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'sm/plugin_sm/Cargo.toml')
-rw-r--r--sm/plugin_sm/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/sm/plugin_sm/Cargo.toml b/sm/plugin_sm/Cargo.toml
new file mode 100644
index 00000000..1d66250d
--- /dev/null
+++ b/sm/plugin_sm/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "plugin_sm"
+version = "0.2.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+[dependencies]
+async-trait = "0.1"
+json_sm = { path = "../json_sm" }
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+thiserror = "1.0"
+tokio = { version = "1.8", features = ["process", "rt"] }
+url = "2.2"
+
+[dev-dependencies]
+anyhow = "1.0"
+env_logger = "0.9.0"
+log = "0.4"
+structopt = "0.3"