summaryrefslogtreecommitdiffstats
path: root/plugins/plugin_mqtt/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/plugin_mqtt/Cargo.toml')
-rw-r--r--plugins/plugin_mqtt/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/plugins/plugin_mqtt/Cargo.toml b/plugins/plugin_mqtt/Cargo.toml
new file mode 100644
index 00000000..be9f14c2
--- /dev/null
+++ b/plugins/plugin_mqtt/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "plugin_mqtt"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+async-trait = "0.1"
+backoff = { version = "0.4", features = ["tokio"] }
+miette = "4.4"
+thiserror = "1"
+log = { version = "0.4", features = ["serde"] }
+futures = "0.3"
+paho-mqtt = "0.10"
+serde = { version = "1", features = ["derive"] }
+tokio = { version = "1", features = [] }
+tokio-util = "0.7.0"
+tracing = "0.1"
+toml = "0.5"
+bevy_reflect = "0.7.0"
+
+tedge_api = { path = "../../crates/core/tedge_api" }
+tedge_lib = { path = "../../crates/core/tedge_lib" }
+