summaryrefslogtreecommitdiffstats
path: root/plugins/plugin_httpstop/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/plugin_httpstop/Cargo.toml')
-rw-r--r--plugins/plugin_httpstop/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/plugin_httpstop/Cargo.toml b/plugins/plugin_httpstop/Cargo.toml
new file mode 100644
index 00000000..13e41c44
--- /dev/null
+++ b/plugins/plugin_httpstop/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "plugin_httpstop"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+async-trait = "0.1"
+log = { version = "0.4", features = ["serde"] }
+serde = { version = "1.0.136", features = ["derive"] }
+miette = "4.4"
+tracing = "0.1"
+tokio = { version = "1", features = ["rt"] }
+tokio-util = "0.7.0"
+hyper = { version = "0.14", features = ["server", "tcp", "http1"] }
+thiserror = "1"
+toml = "0.5"
+
+tedge_api = { path = "../../crates/core/tedge_api" }