summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge_watchdog/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/tedge_watchdog/Cargo.toml')
-rw-r--r--crates/core/tedge_watchdog/Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/crates/core/tedge_watchdog/Cargo.toml b/crates/core/tedge_watchdog/Cargo.toml
index 14088179..c3cb4498 100644
--- a/crates/core/tedge_watchdog/Cargo.toml
+++ b/crates/core/tedge_watchdog/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "tedge_watchdog"
-version = "0.6.0"
+version = "0.6.2"
authors = ["thin-edge.io team <info@thin-edge.io>"]
edition = "2021"
rust-version = "1.58.1"
@@ -9,6 +9,13 @@ description = "tedge_watchdog checks the health of all the thin-edge.io componen
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[package.metadata.deb]
+pre-depends = "tedge"
+assets = [
+ ["../../../configuration/init/systemd/tedge-watchdog.service", "/lib/systemd/system/tedge-watchdog.service", "644"],
+ ["target/release/tedge_watchdog", "/usr/bin/tedge_watchdog", "755"],
+]
+
[dependencies]
anyhow = "1.0"
clap = { version = "3.0", features = ["cargo", "derive"] }