summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge_agent/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/tedge_agent/Cargo.toml')
-rw-r--r--crates/core/tedge_agent/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/core/tedge_agent/Cargo.toml b/crates/core/tedge_agent/Cargo.toml
index b36e26f7..30dafb71 100644
--- a/crates/core/tedge_agent/Cargo.toml
+++ b/crates/core/tedge_agent/Cargo.toml
@@ -25,6 +25,7 @@ stop-on-upgrade = false
agent_interface = { path = "../agent_interface" }
anyhow = "1.0"
async-trait = "0.1"
+clap = { version = "3.0", features = ["cargo", "derive"] }
flockfile = { path = "../../common/flockfile" }
futures = "0.3"
mockall = "0.10"
@@ -32,7 +33,6 @@ mqtt_channel = { path = "../../common/mqtt_channel" }
plugin_sm = { path = "../plugin_sm" }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
-structopt = "0.3"
tedge_config = { path = "../../common/tedge_config" }
tedge_utils = { path = "../../common/tedge_utils", features = ["logging"] }
thiserror = "1.0"