summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/tedge/Cargo.toml')
-rw-r--r--crates/core/tedge/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/crates/core/tedge/Cargo.toml b/crates/core/tedge/Cargo.toml
new file mode 100644
index 00000000..1b3c1456
--- /dev/null
+++ b/crates/core/tedge/Cargo.toml
@@ -0,0 +1,48 @@
+[package]
+name = "tedge"
+version = "0.4.3"
+edition = "2018"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+license = "Apache-2.0"
+readme = "README.md"
+description = "tedge is the cli tool for thin-edge.io"
+
+[package.metadata.deb]
+depends = "mosquitto"
+maintainer-scripts = "configuration/debian/tedge"
+
+[dependencies]
+anyhow = "1.0"
+certificate = { path = "../../common/certificate" }
+chrono = "0.4"
+futures = "0.3"
+hyper = { version = "0.14", default-features = false }
+reqwest = { version = "0.11", default-features = false, features = ["blocking", "json", "rustls-tls", "stream"] }
+rpassword = "5.0"
+rumqttc = "0.10"
+rustls = "0.19"
+serde = { version = "1.0", features = ["derive"] }
+structopt = "0.3"
+tedge_config = { path = "../../common/tedge_config" }
+tedge_users = { path = "../../common/tedge_users" }
+tedge_utils = { path = "../../common/tedge_utils" }
+thiserror = "1.0"
+toml = "0.5"
+url = "2.2"
+webpki = "0.21"
+which = "4.2"
+
+[dev-dependencies]
+assert_cmd = "2.0"
+assert_matches = "1.5"
+mockito = "0.30"
+pem = "1.0"
+predicates = "2.0"
+tempfile = "3.2"
+
+[features]
+integration-test = []
+mosquitto-available = [] # Enable tests requesting mosquitto installed
+root-access = [] # Enable tests requesting root access
+tedge-user = [] # Enable tests requesting a tedge user
+openrc = [] # Enable usage of OpenRC