summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/tedge/Cargo.toml')
-rw-r--r--crates/core/tedge/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/core/tedge/Cargo.toml b/crates/core/tedge/Cargo.toml
index 2180b35c..f19a91e7 100644
--- a/crates/core/tedge/Cargo.toml
+++ b/crates/core/tedge/Cargo.toml
@@ -16,6 +16,7 @@ maintainer-scripts = "../../../configuration/debian/tedge"
anyhow = "1.0"
base64 = "0.13"
certificate = { path = "../../common/certificate" }
+clap = { version = "3", features = ["cargo", "derive"] }
futures = "0.3"
hyper = { version = "0.14", default-features = false }
reqwest = { version = "0.11", default-features = false, features = ["blocking", "json", "rustls-tls", "stream"] }
@@ -25,7 +26,6 @@ rustls = "0.20.2"
rustls_0_19 = {package = "rustls", version = "0.19.0" }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
-structopt = "0.3"
tedge_config = { path = "../../common/tedge_config" }
tedge_users = { path = "../../common/tedge_users" }
tedge_utils = { path = "../../common/tedge_utils" }