summaryrefslogtreecommitdiffstats
path: root/crates/core/plugin_sm/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/plugin_sm/Cargo.toml')
-rw-r--r--crates/core/plugin_sm/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/core/plugin_sm/Cargo.toml b/crates/core/plugin_sm/Cargo.toml
new file mode 100644
index 00000000..1e67dbf3
--- /dev/null
+++ b/crates/core/plugin_sm/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "plugin_sm"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+[dependencies]
+async-trait = "0.1"
+csv = "1.1"
+download = { path = "../../common/download" }
+json_sm = { path = "../json_sm" }
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+tedge_utils = { path = "../../common/tedge_utils" }
+thiserror = "1.0"
+tokio = { version = "1.8", features = ["process", "rt"] }
+tracing = { version = "0.1", features = ["attributes", "log"] }
+url = "2.2"
+
+[dev-dependencies]
+anyhow = "1.0"
+assert_matches = "1.5"
+structopt = "0.3"
+tempfile = "3.2"