summaryrefslogtreecommitdiffstats
path: root/crates/core/c8y_translator/fuzz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/c8y_translator/fuzz/Cargo.toml')
-rw-r--r--crates/core/c8y_translator/fuzz/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/crates/core/c8y_translator/fuzz/Cargo.toml b/crates/core/c8y_translator/fuzz/Cargo.toml
new file mode 100644
index 00000000..7744f66b
--- /dev/null
+++ b/crates/core/c8y_translator/fuzz/Cargo.toml
@@ -0,0 +1,26 @@
+
+[package]
+name = "c8y_translator-fuzz"
+version = "0.0.0"
+authors = ["Automatically generated"]
+publish = false
+edition = "2018"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+libfuzzer-sys = "0.4"
+
+[dependencies.c8y_translator]
+path = ".."
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[[bin]]
+name = "fuzz_target_1"
+path = "fuzz_targets/fuzz_target_1.rs"
+test = false
+doc = false