summaryrefslogtreecommitdiffstats
path: root/crates/core/c8y_translator/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/c8y_translator/Cargo.toml')
-rw-r--r--crates/core/c8y_translator/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/crates/core/c8y_translator/Cargo.toml b/crates/core/c8y_translator/Cargo.toml
new file mode 100644
index 00000000..f4dbdd7d
--- /dev/null
+++ b/crates/core/c8y_translator/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "c8y_translator"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+[dependencies]
+chrono = "0.4"
+clock = { path = "../../common/clock" }
+json-writer = { path = "../../common/json_writer" }
+thin_edge_json = { path = "../thin_edge_json" }
+thiserror = "1.0"
+
+[dev-dependencies]
+anyhow = "1.0"
+assert_matches = "1.5"
+assert-json-diff = "2.0"
+criterion = "0.3"
+pretty_assertions = "1.0"
+proptest = "1.0"
+serde_json = "1.0"
+test-case = "1.2"
+
+[features]
+# use: #[cfg(feature="integration-test")]
+integration-test = []
+
+[[bench]]
+name = "thin_edge_json"
+harness = false