summaryrefslogtreecommitdiffstats
path: root/crates/core/c8y_smartrest/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/core/c8y_smartrest/Cargo.toml')
-rw-r--r--crates/core/c8y_smartrest/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/crates/core/c8y_smartrest/Cargo.toml b/crates/core/c8y_smartrest/Cargo.toml
new file mode 100644
index 00000000..6e0a6289
--- /dev/null
+++ b/crates/core/c8y_smartrest/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "c8y_smartrest"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+[dependencies]
+chrono = { version = "0.4", features = ["serde"] }
+csv = "1.1"
+json_sm = { path = "../json_sm" }
+serde = { version = "1.0", features = ["derive"] }
+thiserror = "1.0"
+
+[dev-dependencies]
+assert_matches = "1.5"
+assert-json-diff = "2.0"
+serde_json = "1.0"
+test-case = "1.2.1"