summaryrefslogtreecommitdiffstats
path: root/crates/common/tedge_utils/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/common/tedge_utils/Cargo.toml')
-rw-r--r--crates/common/tedge_utils/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/crates/common/tedge_utils/Cargo.toml b/crates/common/tedge_utils/Cargo.toml
new file mode 100644
index 00000000..861fff3c
--- /dev/null
+++ b/crates/common/tedge_utils/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "tedge_utils"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+license = "Apache-2.0"
+description = "tedge_utils provide utilities for thin-edge.io components"
+
+[features]
+# No features on by default
+default = []
+logging = ["tracing", "tracing-subscriber"]
+
+[dependencies]
+anyhow = "1.0"
+futures = "0.3"
+tempfile = "3.2"
+thiserror = "1.0"
+tokio = { version = "1.12", default_features = false, features = [ "fs", "io-util", "macros", "rt-multi-thread","signal"] }
+tracing = { version = "0.1", features = [], optional = true }
+tracing-subscriber = { version = "0.2", optional = true }
+
+[dev-dependencies]
+assert_matches = "1.5"
+
+