summaryrefslogtreecommitdiffstats
path: root/crates/common/mqtt_client/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/common/mqtt_client/Cargo.toml')
-rw-r--r--crates/common/mqtt_client/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/crates/common/mqtt_client/Cargo.toml b/crates/common/mqtt_client/Cargo.toml
new file mode 100644
index 00000000..8fd3cc9c
--- /dev/null
+++ b/crates/common/mqtt_client/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "mqtt_client"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+[dependencies]
+async-trait = "0.1"
+mockall = "0.10"
+rumqttc = "0.10"
+thiserror = "1.0"
+tokio = { version = "1.12", features = ["sync", "macros"] }
+
+[dev-dependencies]
+anyhow = "1.0"
+async-log = "2.0"
+env_logger = "0.9"
+futures = "0.3"
+futures-timer = "3.0"
+json = "0.12"
+log = "0.4"
+rand = "0.8"
+serde = "1.0"
+mqtt_tests = { path = "../../tests/mqtt_tests" }
+tokio-test = "0.4"
+
+[features]
+integration-test = []