summaryrefslogtreecommitdiffstats
path: root/crates/common/flockfile/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/common/flockfile/Cargo.toml')
-rw-r--r--crates/common/flockfile/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/crates/common/flockfile/Cargo.toml b/crates/common/flockfile/Cargo.toml
new file mode 100644
index 00000000..91a4e267
--- /dev/null
+++ b/crates/common/flockfile/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "flockfile"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+[dependencies]
+thiserror = "1.0"
+
+[target.'cfg(unix)'.dependencies]
+nix = "0.23"
+tracing = { version = "0.1", features = ["log"] }
+
+[dev-dependencies]
+assert_matches = "1.5"
+tempfile = "3.2"