summaryrefslogtreecommitdiffstats
path: root/crates/common/certificate/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/common/certificate/Cargo.toml')
-rw-r--r--crates/common/certificate/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/crates/common/certificate/Cargo.toml b/crates/common/certificate/Cargo.toml
new file mode 100644
index 00000000..7a15df10
--- /dev/null
+++ b/crates/common/certificate/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "certificate"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+chrono = "0.4"
+rcgen = { version = "0.8", features = ["pem", "zeroize"] }
+sha-1 = "0.9"
+thiserror = "1.0"
+x509-parser = "0.12"
+zeroize = "1.4"
+
+[dev-dependencies]
+anyhow = "1.0"
+assert_matches = "1.5"
+base64 = "0.13"
+pem = "1.0"