summaryrefslogtreecommitdiffstats
path: root/crates/common/certificate/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/common/certificate/Cargo.toml')
-rw-r--r--crates/common/certificate/Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/crates/common/certificate/Cargo.toml b/crates/common/certificate/Cargo.toml
index 0e4a4383..1fa6f19c 100644
--- a/crates/common/certificate/Cargo.toml
+++ b/crates/common/certificate/Cargo.toml
@@ -1,22 +1,23 @@
[package]
name = "certificate"
-version = "0.5.2"
+version = "0.7.4"
authors = ["thin-edge.io team <info@thin-edge.io>"]
edition = "2021"
-rust-version = "1.58"
+rust-version = "1.58.1"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-chrono = "0.4"
-rcgen = { version = "0.8", features = ["pem", "zeroize"] }
-sha-1 = "0.9"
+rcgen = { version = "0.9", features = ["pem", "zeroize"] }
+sha-1 = "0.10"
thiserror = "1.0"
-x509-parser = "0.12"
-zeroize = "1.4"
+time = "0.3"
+x509-parser = "0.14"
+zeroize = "1.5"
[dev-dependencies]
anyhow = "1.0"
assert_matches = "1.5"
base64 = "0.13"
pem = "1.0"
+time = {version = "0.3", features = ["macros"]}