summaryrefslogtreecommitdiffstats
path: root/tests/testcontainers/echoserver/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@ifm.com>2022-09-19 09:04:46 +0200
committerMatthias Beyer <matthias.beyer@ifm.com>2022-09-19 09:05:24 +0200
commit562ca0e2f5cb606415937268832f9b500bd628c7 (patch)
tree4946015f664bb64d79d74e443890952b6a13e7ea /tests/testcontainers/echoserver/Cargo.toml
parent98e686487c9d9af598644af40738527a3ab51bcc (diff)
Add echoserver tedge binary for testcontainer example setuppost-merge/testcontainers
Signed-off-by: Matthias Beyer <matthias.beyer@ifm.com>
Diffstat (limited to 'tests/testcontainers/echoserver/Cargo.toml')
-rw-r--r--tests/testcontainers/echoserver/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/testcontainers/echoserver/Cargo.toml b/tests/testcontainers/echoserver/Cargo.toml
new file mode 100644
index 00000000..20584c3c
--- /dev/null
+++ b/tests/testcontainers/echoserver/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "echoserver"
+version = "0.1.0"
+edition = "2021"
+
+publish = false
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+async-trait = "0.1"
+cfg-if = "1"
+clap = { version = "3", features = ["derive", "cargo", "suggestions"] }
+env_logger = { version = "0.9", optional = true }
+miette = { version = "4.7", features = ["fancy"] }
+hyper = { version = "0.14", features = ["server", "tcp", "http1"] }
+thiserror = "1"
+tokio = { version = "1", features = ["fs", "macros", "rt-multi-thread", "signal"] }
+toml = "0.5.8"
+tracing = "0.1"
+tracing-subscriber = { version = "0.3.11", features = ["env-filter"] }
+
+tedge_api = { path = "../../../crates/core/tedge_api" }
+tedge_core = { path = "../../../crates/core/tedge_core" }
+tedge-cli = { path = "../../../tedge/" }
+