summaryrefslogtreecommitdiffstats
path: root/tedge/Cargo.toml
diff options
context:
space:
mode:
authorPradeepKiruvale <PRADEEPKIRUVALE@gmail.com>2021-03-23 09:13:37 +0530
committerGitHub <noreply@github.com>2021-03-23 09:13:37 +0530
commit58d8468980275eda1bc445049d9dd9a8f822829b (patch)
tree0fd883a5e2a7060b3af3664a2d247c2288abf0b7 /tedge/Cargo.toml
parent2fd5a37cdd594184d1e022baa9c068da92f16a3d (diff)
[CIT-280] Show certificate thumbprint (#101)
* [CIT-280] Show certificate thumbprint * [CIT-280] create a new function to show thumbprint * [CIT-280] refactored code and added a tests to verify the thumbprint * [CIT-280] replace openssl with b64|sha1 * [CIT-280] fixed a typo in test name * [CIT-280] Fixed tests to avoid updaing tedge.toml Co-authored-by: Pradeep K J <pradeekumar.kj@softwareag.com>
Diffstat (limited to 'tedge/Cargo.toml')
-rw-r--r--tedge/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/tedge/Cargo.toml b/tedge/Cargo.toml
index ef4e879f..89608e4d 100644
--- a/tedge/Cargo.toml
+++ b/tedge/Cargo.toml
@@ -30,6 +30,7 @@ url = "2.2.0"
which = "4.0.2"
x509-parser = "0.9.0"
zeroize = "1.2.0"
+sha-1 = "0.9.4"
[dev-dependencies]
assert_cmd = "1.0.2"
@@ -37,6 +38,8 @@ assert_matches = "1.4.0"
mockito = "0.29.0"
pem = "0.8.2"
predicates = "1.0.6"
+crypto-hash = "0.3.4"
+base64 = "0.13.0"
[features]
integration-test = []