summaryrefslogtreecommitdiffstats
path: root/tedge/Cargo.toml
diff options
context:
space:
mode:
authorMichael Neumann <mneumann@ntecs.de>2021-07-13 10:05:47 +0200
committerGitHub <noreply@github.com>2021-07-13 10:05:47 +0200
commit33ace1c0cc88cf54bced5e04a229c690a3ffe08b (patch)
tree4d40823ed4a957d5dcec7b156ab6bbaf367e6fd9 /tedge/Cargo.toml
parente9a75e9e2198ea54327cb5cb9363159efede6933 (diff)
Add system service manager abstraction (#338)
* Refactor code to use abstract `SystemServiceManager`. * Implement Debug for UserManager This simplifies code that embeds a `UserManager` and has to implement `Debug` on it's own as `Debug` cannot be automatically derived. * Add `SystemdServiceManager` * Add NullSystemServiceManager that always fail This can be used as fallback manager where commands that don't need a SystemServiceManager would still work. * Bring in support for OpenRC / BSD service(8) * Add feature flag "openrc" to override the default system service manager that is selected based on the target operation system. For instance, Gentoo has target_os = "linux", but uses OpenRC. OpenRC can also be used on other systems. * Code roughly based on PR #196.
Diffstat (limited to 'tedge/Cargo.toml')
-rw-r--r--tedge/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tedge/Cargo.toml b/tedge/Cargo.toml
index 412c14f4..2326275a 100644
--- a/tedge/Cargo.toml
+++ b/tedge/Cargo.toml
@@ -46,3 +46,4 @@ integration-test = []
mosquitto-available = [] # Enable tests requesting mosquitto installed
root-access = [] # Enable tests requesting root access
tedge-user = [] # Enable tests requesting a tedge user
+openrc = [] # Enable usage of OpenRC