summaryrefslogtreecommitdiffstats
path: root/plugins/tedge_apt_plugin/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@ifm.com>2022-01-10 08:49:09 +0100
committerMatthias Beyer <matthias.beyer@ifm.com>2022-02-18 15:41:57 +0100
commitdf052450ba30e55b5dcd464bca5236e1e995a2b9 (patch)
tree11ec5465c22459808055744582b6554d9f4bc624 /plugins/tedge_apt_plugin/Cargo.toml
parentee2a1c14f338fe5e433d4d58a862994d60fb18f7 (diff)
Replace structopt with clap 3
This patch rewrites the CLI interfaces to be used with clap 3.0 instead of clap 2.x + structopt. The changes are as minimal as possible, although I did not verify that the CLI is the same as before. Signed-off-by: Matthias Beyer <matthias.beyer@ifm.com>
Diffstat (limited to 'plugins/tedge_apt_plugin/Cargo.toml')
-rw-r--r--plugins/tedge_apt_plugin/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/tedge_apt_plugin/Cargo.toml b/plugins/tedge_apt_plugin/Cargo.toml
index 3a2b9515..28d6a152 100644
--- a/plugins/tedge_apt_plugin/Cargo.toml
+++ b/plugins/tedge_apt_plugin/Cargo.toml
@@ -15,7 +15,7 @@ assets = [
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-structopt = "0.3"
+clap = { version = "3", features = ["derive"] }
thiserror = "1.0"
csv = "1.1"
serde = { version = "1", features = ["derive"] }