summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge_watchdog/Cargo.toml
diff options
context:
space:
mode:
authorAlbin Suresh <albin.suresh@softwareag.com>2022-05-27 16:59:53 +0530
committerAlbin Suresh <albin.suresh@softwareag.com>2022-05-27 16:59:53 +0530
commita10c6c119899a8a9b36884e4e93e3f6bd873d793 (patch)
tree40bfb9f047545b7a4ece09e05f6cba2dab41bb35 /crates/core/tedge_watchdog/Cargo.toml
parente3775e430d3109081d3926ab4e7b13b05e1c2741 (diff)
Fix watchdog health check with timestamp validation
Diffstat (limited to 'crates/core/tedge_watchdog/Cargo.toml')
-rw-r--r--crates/core/tedge_watchdog/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/crates/core/tedge_watchdog/Cargo.toml b/crates/core/tedge_watchdog/Cargo.toml
index 7374eb5c..da3647c0 100644
--- a/crates/core/tedge_watchdog/Cargo.toml
+++ b/crates/core/tedge_watchdog/Cargo.toml
@@ -28,5 +28,6 @@ freedesktop_entry_parser = "1.3.0"
tedge_config = { path = "../../common/tedge_config" }
tedge_utils = { path = "../../common/tedge_utils", features = ["logging"] }
thiserror ="1.0.30"
-tokio = { version = "1.12", features = ["sync", "time"] }
+time = { version = "0.3", features = ["formatting", "serde-well-known"] }
+tokio = { version = "1.12", features = ["sync", "time", "rt-multi-thread"] }
tracing = { version = "0.1", features = ["attributes", "log"] }