summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge_watchdog/Cargo.toml
diff options
context:
space:
mode:
authorPradeepKiruvale <pradeepkumar.kj@softwareag.com>2022-04-06 20:27:20 +0530
committerGitHub <noreply@github.com>2022-04-06 20:27:20 +0530
commit3a5f9a1e1cec75e395115567acf17ddce2f6de59 (patch)
tree483ace318460b36b9cf3bc3c6e557e603d291922 /crates/core/tedge_watchdog/Cargo.toml
parent84765d85b6af4ecb1ca5ffa07629eb11c360dbed (diff)
[953] tedge watchdog (#1026)
* [953] tedge-systemd-watchdog * update service file to watchdog * Closes #953 thin-edge watchdog * health check for all the services * update document
Diffstat (limited to 'crates/core/tedge_watchdog/Cargo.toml')
-rw-r--r--crates/core/tedge_watchdog/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/core/tedge_watchdog/Cargo.toml b/crates/core/tedge_watchdog/Cargo.toml
new file mode 100644
index 00000000..65fd3d59
--- /dev/null
+++ b/crates/core/tedge_watchdog/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "tedge_watchdog"
+version = "0.6.0"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2021"
+rust-version = "1.58.1"
+license = "Apache-2.0"
+description = "tedge_watchdog checks the health of all the thin-edge.io components/services."
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0"
+clap = { version = "3.0", features = ["cargo", "derive"] }
+futures = "0.3.21"
+mqtt_channel = { path = "../../common/mqtt_channel" }
+nanoid = "0.4.0"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+freedesktop_entry_parser = "1.3.0"
+tedge_config = { path = "../../common/tedge_config" }
+tedge_utils = { path = "../../common/tedge_utils", features = ["logging"] }
+thiserror ="1.0.30"
+tokio = { version = "1.12", features = ["sync", "time"] } \ No newline at end of file