summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge_watchdog/Cargo.toml
diff options
context:
space:
mode:
authorPradeepKiruvale <pradeepkumar.kj@softwareag.com>2022-04-13 13:47:47 +0530
committerGitHub <noreply@github.com>2022-04-13 13:47:47 +0530
commit25fd0ffed48ff3a1c33470c9e4a3ceaa46f7891e (patch)
treef3a486f543e97b261cf066a00e77b9ff463f5a9c /crates/core/tedge_watchdog/Cargo.toml
parent351423b34cc679cbd5e27c30ea7cecd71ba3a5f9 (diff)
Add watchdog service file (#1078)
Diffstat (limited to 'crates/core/tedge_watchdog/Cargo.toml')
-rw-r--r--crates/core/tedge_watchdog/Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/crates/core/tedge_watchdog/Cargo.toml b/crates/core/tedge_watchdog/Cargo.toml
index 14088179..73cbeb7c 100644
--- a/crates/core/tedge_watchdog/Cargo.toml
+++ b/crates/core/tedge_watchdog/Cargo.toml
@@ -9,6 +9,13 @@ description = "tedge_watchdog checks the health of all the thin-edge.io componen
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[package.metadata.deb]
+pre-depends = "tedge"
+assets = [
+ ["../../../configuration/init/systemd/tedge-watchdog.service", "/lib/systemd/system/tedge-watchdog.service", "644"],
+ ["target/release/tedge_watchdog", "/usr/bin/tedge_watchdog", "755"],
+]
+
[dependencies]
anyhow = "1.0"
clap = { version = "3.0", features = ["cargo", "derive"] }