summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge_mapper/Cargo.toml
diff options
context:
space:
mode:
authorPradeepKiruvale <PRADEEPKIRUVALE@gmail.com>2022-01-11 19:11:07 +0530
committerGitHub <noreply@github.com>2022-01-11 19:11:07 +0530
commit141e93c03c8f9d9a9dd7076830445b3fd9cd5154 (patch)
tree794582fdad064c6021fb02db200f8a7d00260d67 /crates/core/tedge_mapper/Cargo.toml
parent1f41ff7f0909cee0452801f31ab983a581abfd8d (diff)
[663] agent topics (#731)
* move topics to json_sm crate * rename json_sm to sm_interface * format * rename agent interface * fix order of crates * rename crate * rename topics enum * refactor downloader code * move topicerror to error.rs * trigger wf * cargo fmt * address review comments * separate c8y topics * add tests * cargo fmt * change match cases * use download from common crate * update test names * fix the match issue * fix the topic matching * address review comments * remove mqtt dependancy * simplify try_from Co-authored-by: Pradeep Kumar K J <pradeepkumar.kj@sofwareag.com>
Diffstat (limited to 'crates/core/tedge_mapper/Cargo.toml')
-rw-r--r--crates/core/tedge_mapper/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/crates/core/tedge_mapper/Cargo.toml b/crates/core/tedge_mapper/Cargo.toml
index c9a4aca8..8f679205 100644
--- a/crates/core/tedge_mapper/Cargo.toml
+++ b/crates/core/tedge_mapper/Cargo.toml
@@ -25,6 +25,7 @@ start = false
stop-on-upgrade = false
[dependencies]
+agent_interface = { path = "../agent_interface"}
anyhow = "1.0"
async-trait = "0.1"
batcher = { path = "../../common/batcher" }
@@ -33,9 +34,9 @@ c8y_translator = { path = "../c8y_translator" }
chrono = "0.4"
clock = { path = "../../common/clock" }
csv = "1.1"
+download = { path = "../../common/download" }
flockfile = { path = "../../common/flockfile" }
futures = "0.3"
-json_sm = { path = "../json_sm"}
mockall = "0.10"
mqtt_client = { path = "../../common/mqtt_client" }
reqwest = { version = "0.11", default-features = false, features = ["json", "rustls-tls"] }